Enviado por héctormiguelvarela el Dom, 25/07/2021

Buenas tardes, en este modulo tengo tal situación, cuando estoy en local con acquia me pasa que el remoto me sale, en archivos multimedia sale el video pero cuanto voy a verlo me sale Not Found The requested URL was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. hay que configurar algo más de estos archivos remotos cuando es media??

y si lo tengo en un hosting sale perfecto. no se a que se puede deber el tema del oembed que en local de acquia no lo pueda ver

 

  1. Hola Héctor, puedes indicar cual es el módulo que estas utilizando? si es de la comunidad, indica el enlace por favor.

    Si no es contribuido y es Media del core, como estás intentando introducirlo? porque si usas Media library en CKeditor, puedes configurar el botón de insertar Media en un editor de texto, como en este video.

    Este es el icono para embeber los Media:

    Icono media library en el ckeditor

    Con el, podras añadir videos de Youtube y Vimeo a media y embeberlos dentro del CKeditor sin modulos de la comunidad.

  2. héctormiguelvarelaLun, 26/07/2021

    Que tal y gracias por estar activo en la respuesta, el problema lo tengo con oembed  de videos, en la barra de navegación deje el insertar videos oembed que son el dibujo que marcastes que no me funciona y despues esta el común de insertar videos que ese si funciona

    los módulos  que uso son media y con ese no va ni para atras ni para adelante con videos por eso creo que es algo que me falta de oembed o no se si sera porque esta en local con Acquia.

    Las dos formas de video

    Consulta urgente aparte.

    Podrás hacer un video de como pasar el sitio hecho en acquia en local para pasarlo a un hosting, porque lo tengo casi terminado y no le encuentro la vuelta de como hacer para subir todo el sitio al servidor y que funcione, lo separe ademas por base de datos y archivos y nada, sino tendré que hacerlo todo a mano en el servidor y olvidarme de hacer algo en local porque nadie vi que de en la tecla con este tema y los dos o tres que hay son de diez años atras y con el cambio de la tecnología siempre falla. Lo que si me funciono a la perfección fue el composer update, dejo actualizado el sitio.

    Poder pasar todo el contenido con nodos incluidos. no se que hay que hacer ni que tocar porque lo hice paralelo y lo deje así sin hacer nada más porque no voy para ningún lado en este tema. Eso acobarda en estar en Drupal, perdes el hilo de configuración de entornos.

    No se si hay que editar el setting y que datos poner de acquia o no y si el .htaccess hay que meterle mano o no, abrazo y espero si me podes orientar y gracias

     

  3. Que no te funcione el embebido con el botón de Media, puede ser porque no has configurado la opción de que se muestren, mira en la configuración del editor que estés usando, que tengas activada la opcion de embeberlo (aparte del boton en la barra), y tambien el como se tienen que mostrar.

    Insertar el Media

    Y configurar esta opcion con el modo de vista que prefieras:

    Configurar como mostrar el elemento Media

    Puede haber un problema, si tienes configurado un dominio/sub-dominio personalizado para embeber los iframe de Media:

    Configurar el dominio de Media para los iframe.

    Si el dominio no está bien, es posible que no te funcione correctamente.

    ----------------------------------

    Sobre el oEmbed, yo no tengo el boton de insertar video que te aparece a ti, no se si lo habras añadido con algun modulo de la comunidad, pero a mi no me aparece.

    Barra del ckeditor de Drupal sin el icono de video.

    Comentarte, que no todos los sitios soportan oEmbed, y seguramente necesites contratar un servicio externo para algunas funcionialidades, ya que el core de Drupal únicamente soporta Youtube y Vimeo.

    Existe el modulo de Media Embed Plugin, pero no es facil de configurar y tienes que utilizar algun servicio externo, que los gratuitos son con usos limitados o soportan muy pocos sitios, y los de pago, pues a mi me parecen excesivamente caros y no estan preparados para sitios pequeños.

    --------------------------

    Sobre el pase a producción, tienes que copiar todos los archivos de Drupal al hosting, subir tambien la base de datos y en el archivo settings.php que está en /sites/default configurar los datos de acceso a la base de datos. Mas que un video, mirare de hacer un articulo, pero eso es casi imposible de hacer, porque existen cientos de proveedores de alojamiento, cada uno con sus limites y particularidades, a si que aunque yo haga un video/articulo, puede no servirle a nadie, por configurar algunas cosas que tal vez no sea posible en el alojamiento. Pero para continuar con eso, otro hilo, que este es sobre Media :)