Drupal 10 requerira PHP 8

Symfony y Drupal

PHP esta evolucionando muy rápido, y esto implica que todo el software que lo usé debe seguir un buen ritmo de actualizaciones para mantener la compatibilidad; ya que al lanzar versiones nuevas están dejando de dar soporte a versiones mas antiguas, con lo cual al final, estamos forzados a estar a la ultima para evitar problemas de seguridad.

Debido a esto, durante el ciclo de vida de Drupal 8, tuvieron que aumentar la versión mínima soportada, de no haber hecho ese cambio les resultaría imposible mantener compatibilidad con las versiones más modernas.

Para evitar mas problemas como este, en Drupal 9 subieron la versión mínima a PHP 7.3, ya que facilitaría mucho el soportar la futura versión mayor de PHP, la 8.0, que fue lanzada en noviembre del 2020.

Drupal home

Drupal 10 utilizará Symfony 6

Hace ya muchos años se decidió adoptar Symfony para estandarizar Drupal y tratar de mejorar la base para que la calidad del software fuera mejor y hacerla más fácil de mantener y utilizar.
Leer mas

Drupal 10 y Symfony 6

Ahora se encuentra con el caso de que hacer en Drupal 10, y es un mucho más fácil de solucionar. Por un lado, Symfony 6 requerirá como mínimo PHP 8.0, y teniendo en cuenta que quieren lanzar Drupal 10 con esa versión de Symfony, pues tiene que ponerla como mínima si o si, no tiene mas opciones. Por otro lado, esta que PHP 7.4 perderá soporte 6 meses después del lanzamiento de Drupal 10 en junio del 2022 si todo va según lo planeado.

Sabiendo esto, pues es muy lógico que Drupal 10 vaya a requerir como mínimo PHP 8.0, ya que no tienen más opciones que hacerlo.

 

Comparte este artículo:
Publicado por Borja
Image

Me metí en la aventura de Drupal con la versión 6, y aquí estoy, 10 años después, escribiendo articulos y haciendo videos sobre Drupal, quien me lo iba a decir. Aunque he probado otros framworks y cms, me quedo con Drupal de lejos, pero Symfony y Django estan entre mis favoritos. Aficionado a la montaña, la bicicleta, y el comer, de eso que no falte.